Current Classifieds

Need a 1976 runabout instrument cluster replacement
Date: 12/26/2016 04:29 pm
hubcaps

Date: 06/05/2018 09:13 pm
Rally spoiler wanted
Date: 05/04/2017 01:32 pm
free transmissions
Date: 11/28/2019 10:21 am
Need Interior Panels
Date: 07/09/2018 04:59 pm
1979 Pinto Rear Bumper
Date: 03/26/2021 03:26 pm
1971 Pinto

Date: 03/04/2017 11:28 pm
Wanted 2.3 engine mount brackets and mounts
Date: 02/14/2018 01:34 am
1974 Pinto Misc. moldings & parts

Date: 12/20/2016 10:47 pm
Need lower control arms for 1973 pinto
Date: 02/27/2017 10:10 pm
77 pinto
Date: 08/22/2017 06:31 pm
Cruiser Dash Gauges
Date: 12/04/2016 11:50 am

Author Topic: Idle/exhaust issue  (Read 836 times)

0 Members and 1 Guest are viewing this topic.

Offline dedinski

  • Pinto Member
  • **
  • Posts: 22
  • FeedBack: +0/-0
  • Gender: Male
  • Another Pinto Driver
    • Contact Info

  • Total Badges: 4
    Badges: (View All)
    Topic Starter Poll Voter Windows User Webmaster
Idle/exhaust issue
« on: July 15, 2014, 07:41:12 PM »
So my idle is rough and engine light kinda flickers on while idling but if I give a tiny bit of gas it all stops. Also when I take off I have some white exhaust...but when I get going everything is fine...any ideas?

Offline 82expghost

  • Pinto Full Member
  • ***
  • Posts: 154
  • FeedBack: +84/-0
  • Die tires die!

  • Total Badges: 5
    Badges: (View All)
    Topic Starter Signature Fifth year Anniversary Mobile User Windows User
Re: Idle/exhaust issue
« Reply #1 on: July 15, 2014, 10:41:21 PM »
check idle speed, my sticker on my engine said 850, also older carburated engines make white smoke while warming up, from normal condensate in the exhaust ,intake, gas from sitting, and alot of fuel additives can cause it. but nothing to be really worried about. you will get more if you dont have a cat. the only other thing that it could also be is a stuck pcv valve dumping exhaust into your intake bogging your engine down. thats about it
98 taurtus, now in heaven
82 exp, the race car, cancer took it away
77 pinto, weekend warrior
92 grand marquis, daily

Offline dedinski

  • Pinto Member
  • **
  • Posts: 22
  • FeedBack: +0/-0
  • Gender: Male
  • Another Pinto Driver
    • Contact Info

  • Total Badges: 4
    Badges: (View All)
    Topic Starter Poll Voter Windows User Webmaster
Re: Idle/exhaust issue
« Reply #2 on: July 16, 2014, 05:48:16 AM »
Thanks. I also checked my radiator after it cooled down because it seemed like the engine was running too hot and the dang guy didnt have any coolant in the thing grrrr best I can hope for is put coolant in it and hope no damage was done in the short drive I took it on. Not very happy about that right now