Current Classifieds

72 Pinto racecar, 2.3 ARCA engine, Quaife trans
Date: 01/10/2022 03:41 pm
'71,'72,or'73 small Ford v8 Pinto
Date: 01/23/2017 07:41 am
72 Pinto racecar, 2.3 ARCA engine, Quaife trans
Date: 01/10/2022 03:41 pm
2.3 engine and other parts- Free
Date: 12/13/2016 10:25 am
2 liter blocks and heads
Date: 03/28/2018 09:58 am
1977 Front Sump 2.3 Oil Pan
Date: 09/14/2018 11:42 pm
Need right door for pinto or bobcat 1977 to 1980 station wagon
Date: 08/03/2018 09:19 am
Pinto Fiber Glass Body Parts
Date: 01/06/2019 06:53 pm
1973 Pinto Runabout

Date: 03/25/2019 09:02 pm
pinto floor mats??

Date: 01/11/2017 07:27 am
Wheel cap
Date: 04/25/2022 11:21 pm
WTB: Ford Type 9 5 speed Transmission
Date: 06/28/2019 09:14 pm

Author Topic: starter  (Read 405 times)

0 Members and 1 Guest are viewing this topic.

Offline cobra

  • Pinto Member
  • **
  • Posts: 14
  • FeedBack: +2/-0
  • Gender: Male
  • Another Pinto Driver

  • Total Badges: 2
    Badges: (View All)
    Topic Starter Fifth year Anniversary
starter
« on: August 14, 2018, 08:04:47 PM »
I have a strange problem with my 74 2.3l pinto engine. First it's in a kit car and has a GM
steering column. No electrical problems. I was having starting problems (car sat a while before starts) so I installed an electric fuel pump. Gas problem solved. Then reading post here decided to put on a 2.3 Ranger starter. The combination was great. Fired right up. The next time the starter just clicked. After about 3 times it spun the engine and started right up. This happens all the time. Any ideas?