Current Classifieds

Early Rare Small window hatch
Date: 08/16/2017 08:26 am
79 Wagon with many extras
Date: 07/08/2020 04:18 pm
2.3 carb intake

Date: 07/15/2020 09:25 pm
Need a 1976 runabout instrument cluster replacement
Date: 12/26/2016 04:29 pm
Front sway bar frame brackets
Date: 07/13/2017 01:05 am
2.0 Mickey Thompson SUPER RARE Rocker cover and belt guard
Date: 08/22/2017 09:21 pm
Weber dcoe intake 2.0

Date: 08/01/2018 01:09 pm
Alloy Harmonic Balancer

Date: 07/10/2020 12:17 pm
Front Body parts needed
Date: 02/09/2018 06:09 pm
1976 Ford Pinto

Date: 07/16/2019 02:51 am
73 rear hatchback glass
Date: 07/06/2017 11:33 am
1978 pinto grill
Date: 07/24/2018 02:18 pm

Author Topic: 2.3L issue with idling  (Read 1341 times)

0 Members and 1 Guest are viewing this topic.

Offline MitchiePinto

  • Pinto Member
  • **
  • Posts: 76
  • FeedBack: +0/-0
  • Another Pinto Driver

  • Total Badges: 1
    Badges: (View All)
    Topic Starter
2.3L issue with idling
« on: September 05, 2012, 01:32:45 PM »
When I bought the car it was hard to start and had a leaking carb and idle was lumpy but it wouldn't quit and would run ok at about 500-650 rpm idle

Now I rebuilt the carb it starts easy but I have to keep my foot on the gas until it warms up (takes 6 mins) it idles at 2000 rpm when cold then around 1500 rpm when hot

The carb mixture is set lean (If I ran it richer it would bog out) Idle speed is set around 1500 rpm if I set it any lower the car would stall improperly

I suspect a vacuum leak (Il check with propane)

My carb is a 2100 Motorcraft without a choke mech.

Also I have a racing cam put into the head everything else in the engine bay is stock

Offline MitchiePinto

  • Pinto Member
  • **
  • Posts: 76
  • FeedBack: +0/-0
  • Another Pinto Driver

  • Total Badges: 1
    Badges: (View All)
    Topic Starter
Re: 2.3L issue with idling
« Reply #1 on: September 08, 2012, 03:26:46 PM »
UPDATE: Got the car running !!!!

The issue was the wrong power valve

In the kit it came with a 2 stage (I think) #28 power valve which made the car run rich and only stay running around 2000 rpm

I poped in my old power valve 1 stage #16 and fought with the float level until i got the smoothest idle

Now it idles around 500-750rpm (carb mixture screw's are set at 1 1/2 turns out )

No vacuum leaks, Car can handle slopes,loads and has no bogging or hesitating and the dieseling issue stopped

I have only the vacuum advance, PCV (from the air filter to the thing on top of the valve cover way in the back)

NOW one last issue the car has a mild lumpy idle like it wants to stall and if you listen closely you can hear a slight missfiring on idle and it vibrates some.

My hypothesis is that all this is being caused by the racing cam in it and I should check the ignition timing and advance the cam timing a little


Other than that the car is great it would do 100km all day long and Cruise fine its just the idle issue and I think it has an  overheating issue but im not sure. What are signs of overheating