Current Classifieds

'71,'72,or'73 small Ford v8 Pinto
Date: 01/23/2017 07:41 am
Pinto Wagon
Date: 05/25/2018 01:50 pm
1972 Rallye wagon rebuild
Date: 11/14/2020 07:31 pm
73 actuator for heater blend door
Date: 09/19/2019 04:43 pm
Mini Mark IV one of 2 delux lg. sunroof models
Date: 06/18/2018 03:47 pm
SEARCHING HOPELESSLY
Date: 02/02/2017 07:21 am
Need a 1976 runabout instrument cluster replacement
Date: 12/26/2016 04:29 pm
71 72 front bumper brackets
Date: 06/10/2020 10:55 am
76 station wagon parts needed.
Date: 03/14/2020 01:52 pm
Wanted Postal Pinto
Date: 09/26/2019 05:31 pm
1974 Pinto Passenger side door glass and door parts

Date: 02/18/2017 05:55 pm
Clutch Pedals for 75to 80 Pinto
Date: 09/21/2018 11:35 am

Author Topic: ford 2.3 issues...stumped and need help with this motor please!  (Read 1464 times)

0 Members and 1 Guest are viewing this topic.

Offline Basher13

  • Pinto Driver
  • *
  • Posts: 5
  • FeedBack: +0/-0

  • Total Badges: 3
    Badges: (View All)
    Topic Starter Tenth year Anniversary Fifth year Anniversary
I have a ford 2.3 in a dirt track car.  It has a comp cam, double springs, anti pump lifters, adjustable cam gears, holley 500 carb, carter marine aftermarket electric fuel pump, accell hi voltage coil. stock points distributor, race gas used. 
Here is the problem......t he motor idles fine.  when you take it up to about half throttle and hold it there it develops a bad miss.  same things happens in gear.  can idle or rev high and its smooth.  Hold the throttle and it misses in gear or out of gear.
what I have tried....new plugs, new wires, adjusted distributor for timing issues, no vacuum leaks that I can tell, new gas, tried 2 different Holley 500 and did the same thing.
Any ideas on what could be the problem?

Offline rramjet

  • Pinto Full Member
  • ***
  • Posts: 120
  • FeedBack: +3/-0
  • Another Pinto Driver

  • Total Badges: 1
    Badges: (View All)
    Topic Starter
Re: ford 2.3 issues...stumped and need help with this motor please!
« Reply #1 on: July 29, 2014, 11:56:53 AM »
How about distributor cap, points, condenser, rotor. Might have spark  jumping. Look for carbon tracks in/on cap. What does a timing light show? Timing mark nice and steady?

Offline 72pair

  • Pinto Sr. Member
  • ****
  • Posts: 269
  • FeedBack: +56/-0
  • Gender: Male

  • Total Badges: 6
    Badges: (View All)
    Tenth year Anniversary Topic Starter Signature Poll Voter Windows User Fifth year Anniversary
Re: ford 2.3 issues...stumped and need help with this motor please!
« Reply #2 on: July 29, 2014, 03:57:58 PM »
Hold at half throttle and see if fuel is siphoning out of the accelerator pump squirter. Had this problem before with the 500. If so, a heavier check valve under the pump squirter will help. Holley makes an anti=pullover squirter also. I had luck using long tube squirts with the heaviest check I had...had a stainless one from an alcohol kit. 
72 sedan 2.0, c-4 beater now hot 2.0, 4-speed
72 sedan 2.3, t-5, 8" running project
80 Bobcat hatchback 2.3, 4-spd, 97K

Offline 65ShelbyClone

  • Pinto Master
  • *****
  • Posts: 756
  • FeedBack: +139/-0
  • Soylent Green

  • Total Badges: 7
    Badges: (View All)
    Fifth year Anniversary Topic Starter Signature Poll Voter Mobile User Linux User Windows User
Re: ford 2.3 issues...stumped and need help with this motor please!
« Reply #3 on: July 30, 2014, 11:54:55 AM »
Any ideas on what could be the problem?

Fuel starvation?
'72 Runabout - 2.3T, T5, MegaSquirt-II, 8", 5-lugs, big brakes.
'68 Mustang - Built roller 302, Toploader, 9", etc.

Offline tbucketjack

  • Pinto Full Member
  • ***
  • Posts: 107
  • FeedBack: +0/-0
  • Gender: Male

  • Total Badges: 6
    Badges: (View All)
    Topic Starter Poll Voter Linux User Mobile User Windows User Fifth year Anniversary
Re: ford 2.3 issues...stumped and need help with this motor please!
« Reply #4 on: July 30, 2014, 03:10:43 PM »
Float adjustment?