32 Guests, 1 User
LongTimeFordMan

Author Topic: DIS 2.3 Swap - Check engine light and codes present  (Read 1983 times)

0 Members and 1 Guest are viewing this topic.

Offline pintoguy76

  • Pinto Master
  • *****
  • Posts: 936
  • FeedBack: +11/-0
  • Gender: Male
  • Pinto Driver

  • Total Badges: 7
    Badges: (View All)
    Topic Starter Signature Mobile User Poll Voter Tenth year Anniversary Windows User Fifth year Anniversary
DIS 2.3 Swap - Check engine light and codes present
« on: January 31, 2014, 11:30:01 PM »
OK heres whats going on. I have a 91 mustang 2.3 DIS in my 74 wagon. It starts and runs good except for a couple minor glitches here and there. For example, if the engine is at idle or low RPM.... in gear.... and I floor the throttle, it will buck and jerk like an angry bull at a rodeo. Any other time its fine. I can floor it as long as it isnt near idle when I do it.


Also after driving for a while the check engine light comes on, and the engine begins to stumble and loose power. After a few seconds it clears up but the check engine light stays on until i shut the car off. Then its the same thing again after a bit.


Not really sure what the deal is. Here are the codes and what my book says is the problem. Key on, engine off.


116 Engine coolant temperature higher or lower than expected


172 Heated exhaust gas oxygen sensor fault/lean


173 Heated exhaust gas oxygen sensor fault/rich


186 Fault in injector pulse width circuit/high


223 Loss of dual plug inhibit control


224 Erratic IDM output to processor


332 Insufficient EGR flow detected


334 EGR closed valve voltage high


Note: I have not yet cleared the codes. The ignition module was replaced a while back, and the oxygen sensor was replaced just yesterday. The car is not driven much, so it is possible some of these codes could be old, but I am not sure.


Can anyone help?
1974 Ford Pinto Wagon with 1991 Mustang DIS EFI 2.3 and stock Pinto 4 Speed
 
1996 Chevy C2500 Suburban with 6.5L Turbo Diesel/4L80E 4x2

1980 Volvo 265 with 1997 S-10 4.3 and a modified 700R4

2010 GMC Sierra SLE 1500 4x2 5.3 6L80E

RSM

  • Guest
Re: DIS 2.3 Swap - Check engine light and codes present
« Reply #1 on: February 01, 2014, 12:00:19 AM »
I'd start by clearing the codes. That gives you a clean slate and a better starting point. Then run the car thru the paces and see what shows up.

Offline pintoguy76

  • Pinto Master
  • *****
  • Posts: 936
  • FeedBack: +11/-0
  • Gender: Male
  • Pinto Driver

  • Total Badges: 7
    Badges: (View All)
    Topic Starter Signature Mobile User Poll Voter Tenth year Anniversary Windows User Fifth year Anniversary
Re: DIS 2.3 Swap - Check engine light and codes present
« Reply #2 on: February 01, 2014, 01:33:23 AM »
Ok. Codes cleared. Engine was not warmed up the first time so I think that the 116 code was due to that.


However, now we have code 114 as well as 558, 332, and 334. The rest of the  codes are gone.


114 Air charge temperature sensor higher or lower than expected voltage.


558 EGR valve regulator solenoid circuit fault


332 Insufficient EGR flow detected


334 EGR closed valve voltage high
1974 Ford Pinto Wagon with 1991 Mustang DIS EFI 2.3 and stock Pinto 4 Speed
 
1996 Chevy C2500 Suburban with 6.5L Turbo Diesel/4L80E 4x2

1980 Volvo 265 with 1997 S-10 4.3 and a modified 700R4

2010 GMC Sierra SLE 1500 4x2 5.3 6L80E

Offline amc49

  • PCCA VIP
  • Pinto Master
  • ***
  • Posts: 1256
  • FeedBack: +242/-1
  • Another Pinto Driver

  • Total Badges: 4
    Badges: (View All)
    Topic Starter Poll Voter Windows User 1000 Posts
Re: DIS 2.3 Swap - Check engine light and codes present
« Reply #3 on: February 01, 2014, 05:02:47 AM »
The EGR codes at least could be from the 558, the others may result from that, PCM detects it has sent voltage to solenoid, but result coming back not what it expects (the other two codes). I'd verify that solenoid works and power to it.


Offline pintoguy76

  • Pinto Master
  • *****
  • Posts: 936
  • FeedBack: +11/-0
  • Gender: Male
  • Pinto Driver

  • Total Badges: 7
    Badges: (View All)
    Topic Starter Signature Mobile User Poll Voter Tenth year Anniversary Windows User Fifth year Anniversary
Re: DIS 2.3 Swap - Check engine light and codes present
« Reply #4 on: February 09, 2014, 09:34:10 PM »
Haven't totally verified it yet, but I believe the EGR Valve Position sensor was the problem. I changed it and then drove it all day after replacing that part with no more engine light coming on....

So. That may take care of all the codes. The 114 ACT code might just be due to running a KOEO test on a cold engine....
1974 Ford Pinto Wagon with 1991 Mustang DIS EFI 2.3 and stock Pinto 4 Speed
 
1996 Chevy C2500 Suburban with 6.5L Turbo Diesel/4L80E 4x2

1980 Volvo 265 with 1997 S-10 4.3 and a modified 700R4

2010 GMC Sierra SLE 1500 4x2 5.3 6L80E

Offline pintoguy76

  • Pinto Master
  • *****
  • Posts: 936
  • FeedBack: +11/-0
  • Gender: Male
  • Pinto Driver

  • Total Badges: 7
    Badges: (View All)
    Topic Starter Signature Mobile User Poll Voter Tenth year Anniversary Windows User Fifth year Anniversary
Re: DIS 2.3 Swap - Check engine light and codes present
« Reply #5 on: March 02, 2014, 10:01:34 PM »
It appears the EGR Position sensor was the problem. I replaced it and  there is no more check engine light :)
1974 Ford Pinto Wagon with 1991 Mustang DIS EFI 2.3 and stock Pinto 4 Speed
 
1996 Chevy C2500 Suburban with 6.5L Turbo Diesel/4L80E 4x2

1980 Volvo 265 with 1997 S-10 4.3 and a modified 700R4

2010 GMC Sierra SLE 1500 4x2 5.3 6L80E

Offline amc49

  • PCCA VIP
  • Pinto Master
  • ***
  • Posts: 1256
  • FeedBack: +242/-1
  • Another Pinto Driver

  • Total Badges: 4
    Badges: (View All)
    Topic Starter Poll Voter Windows User 1000 Posts
Re: DIS 2.3 Swap - Check engine light and codes present
« Reply #6 on: March 03, 2014, 03:27:08 AM »
Luck.......... .............. .